rules 556 B

123456789101112131415161718192021
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # extract the last section of the changelog version for extra info
  4. DEB_VERSION ?= $(shell dpkg-parsechangelog -S Version)
  5. DEB_VERSION_EXTRA := $(lastword $(subst -, ,$(DEB_VERSION)))
  6. # Uncomment this to turn on verbose mode.
  7. #export DH_VERBOSE=1
  8. %:
  9. dh $@ --buildsystem=cmake --parallel
  10. override_dh_auto_configure:
  11. dh_auto_configure -- \
  12. -DPOTHOS_EXTVER="$(DEB_VERSION_EXTRA)" \
  13. -DCMAKE_AUTOSET_INSTALL_RPATH=FALSE \
  14. -DENABLE_TOOLKITS=OFF
  15. override_dh_installchangelogs:
  16. dh_installchangelogs Changelog.txt